Tampilkan postingan dengan label KOMUNIKASI DATA DAN JARINGAN. Tampilkan semua postingan
Tampilkan postingan dengan label KOMUNIKASI DATA DAN JARINGAN. Tampilkan semua postingan

Kamis, 25 Juli 2019

IOS Command Line

Alamat Referensi : 172.20.0.0/16

Router 1
LAN 1 : 350 Host
LAN 2 : 175 Host

Router 2
LAN 3 : 25 Host
LAN 4 : 50 Host

Langkah 1. Cari nilai slash dari masing-masing host dan di urutkan dari host terbesar.

LAN 1 : 350 Host
2 - 2 ≥ 350
n = 9 / 23 ( +2 di byte-3 )

LAN 2 : 175 Host
2 - 2 ≥ 175
n = 8 / 24 ( +1 di byte-3 )

LAN 4 : 50 Host
2 - 2 ≥ 50
n = 6 / 26 ( +64 di byte-4 )

LAN 3 : 25 Host
2 - 2 ≥ 25
n = 5 / 27 ( +32 di byte-4 )

Berhubung ada jaringan WAN yang menghubungkan 2 Router, maka router menjadi host.

WAN : 2 host
2 - 2 = 2
n = 2 / 30 ( +4 di byte-4 )

Langkah 2. Masukan IP address pada network dan host

LAN 1 : 172.20.0.0/23 ini subnetmasknya 255.255.254.0
g0/0 : 172.20.0.1 = Gateway LAN 1
PC1 : 172.20.0.2

LAN 2 : 172.20.2.0/24 ini subnetmasknya 255.255.255.0
g0/1 : 172.20.2.1
PC2 : 172.20.2.2

LAN 4 : 172.20.3.0/26 ini subnetmasknya 255.255.255.192
g0/1 : 172.20.3.1
PC4 : 172.20.3.2

LAN 3 : 172.20.3.64/27 ini subnetmasknya 255.255.255.224
g0/0 : 172.20.3.65
PC3 : 172.20.3.66

WAN : 172.20.3.96/30
R1(S0/0/0) = 172.20.3.97
R2(S0/0/1) = 172.20.3.98

Langkah 3. Mencari static Routingnya

Static routing ini di dapat dari IP LAN yang ada pada router lain.

Contoh : Router 1 (LAN 1 dan LAN 2), Maka static routing Router 1 adalah (LAN 3 dan LAN 4), maka didapat sebagai berikut.

R1(config) # IP route 172.20.3.0 255.255.255.192 s0/0/0
R1(config) # IP route 172.20.3.64 255.255.255.224 s0/0/0

R2(config) # IP route 172.20.0.0  255.255.254.0 s0/0/1
R2(config) # IP route 172.20.2.0  255.255.255.0 s0/0/1

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

Berikut ini saya urutkan bagaimana cara mengkonfigurasinya :

1. Masuk ke Menu IOS Command Line / CLI pada Router 1

Router>enable
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface g0/0
R1(config-if)#ip address 172.20.0.1 255.255.254.0
R1(config-if)#no shutdown


R1(config-if)#conf t
%Invalid hex value ( biarkan saja )
R1(config)#interface g0/1
R1(config-if)#ip address 172.20.2.1 255.255.255.0
R1(config-if)#no shutdown

R1(config-if)#do write
Building configuration...

[OK]


2. Masuk ke Menu IOS Command Line / CLI pada Router 2

Router>enable
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface g0/1
R2(config-if)#ip address 172.20.3.1 255.255.255.192
R2(config-if)#no shutdown

R2(config-if)#conf t
%Invalid hex value ( biarkan saja )
R2(config)#interface g0/0
R2(config-if)#ip address 172.20.3.65 255.255.255.224
R2(config-if)#no shutdown

R2(config-if)#do write
Building configuration...

[OK]

3. Kembali ke Router 1, kemudian ikuti langkah-langkah berikut ini.


R1>enable
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface s0/0/0
R1(config-if)#ip address 172.20.3.97 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#clock rate 64000

R2>enable
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#interface s0/0/1
R2(config-if)#ip address 172.20.3.98 255.255.255.252
R2(config-if)#no shutdown


4. Masukan alamat IP pada masing-masing PC



5. Masukan Static Routing

R1>enable
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ip route 172.20.3.0 255.255.255.192 s0/0/0
R1(config)#ip route 172.20.3.64 255.255.255.224 s0/0/0
R1(config)#do write
Building configuration...
[OK]

R2(config-if)#conf t
%Invalid hex value
R2(config)#ip route 172.20.0.0 255.255.254.0 s0/0/1
R2(config)#ip route 172.20.2.0 255.255.255.0 s0/0/1
R2(config)#do write
Building configuration...
[OK]

6. Tes koneksi dengan cara mengirim pesan kepada PC yang berbeda router.





Menghubungkan LAN ke Router

Roating adalah proses komunikasi data apabila host sumber berada pada jaringan yang berbeda dengan host tujuan.

LAN 1 : 10.11.12.0/24
LAN 2 : 11.12.13.0/24



LAN 1 : 10.11.12.0/24
g0/0 : 10.11.12.1
PC1 : 10.11.12.2
PC2 : 10.11.12.3
GATEWAY LAN 1 : 10.11.12.1
Subnetmask : 255.255.255.0

LAN 2 : 11.12.13.0/24
g0/1 : 11.12.13.1
PC3 : 11.12.13.2
PC4 : 11.12.13.3
GATEWAY LAN 2 : 11.12.13.1
Subnetmask : 255.255.255.0

Routing table dari kumpulan alamat network.

Kode Alamat Network Keterangan interface
C 10.11.12.0/24 is directly connected g0/0
C 11.12.13.0/24/24 is directly connected g0/1

Saya akan mendemokan dengan software cisco packet tracer,





Router tipe 1941
Switch tipe 2960
End device : PC
Connections : Cooper Straight-Through





Router yang digunakan dengan physical HWIC-2T, Port yang berada pada pojok kanan bawah kita geser ke router di atas yang masih kosong. Sebelum memasang ataupun mencopot, kita harus mematikan routernya terlebih dahulu.


Kita masuk ke menu CLI,

-- System Configuration Dialog --
Continue with configuration dialog? [yes/no] : no
Router # configure terminal
Router (config) # hostname R1
R1 (config) # interface g0/0
R1 (config-if) # ip address 10.11.12.1 255.255.255.0
R1 ( config-if) # no shutdown

koneksikan juga router ke lan 2

R1 (config) # interface g0/0
R1 (config-if) # ip address 10.11.12.1 255.255.255.0
R1 ( config-if) # no shutdown

-----

Disini kita telah selesai menghubungkan Router 1 ke Lan 1 dan Lan 2.